XenForo 2.1.0 Beta 5 & Add-ons 2.1.0 Preview 2 Released (Unsupported)

dinhphucv

Well-known member
Staff member
Administrator
Moderator
Uploader
XF Premium
Credits
2.246
Today, we continue the beta stage of XenForo 2.1 with Beta 5. This release fixes a number of bugs found since the previous releases.

Alongside this release, we have released 2.1.0 Preview 2 of each of our official add-ons. These include further adjustments to account for the changes and new systems present in 2.1.

We strongly recommend anyone testing 2.1 during this beta period upgrade as each beta/preview version is released.

More specific details regarding bugs fixed in this release can be found in the resolved bugs forum.

This is beta software. It is not officially supported. We do not recommend running it in production.

Please remember that this is beta software. It contains known bugs and incomplete functionality. We do not recommend running beta software in a production environment, and support is limited at this time to questions here on the community forums.

XenForo 2.1 is a significant upgrade. Add-ons and custom styles may be broken after upgrading to 2.1. You must test your add-ons thoroughly or look for updates. Be especially careful with add-ons that cover similar features to ones that are added to 2.1; these may conflict with the core XenForo data. If data conflicts are found, they will need to be resolved in a new add-on release or by removing the add-on before upgrading to 2.1.

If you choose to run beta software, it is your responsibility to ensure that you make a backup of your data. We recommend you do this before attempting an upgrade. If in doubt, always do a test upgrade on a copy of your production data.

All customers with active licenses may now download the new version from the customer area.

Current requirements

The following are minimum requirements:
  • PHP 5.6 or newer (PHP 7.2 recommended)
  • MySQL 5.5 and newer (MySQL 5.7/8.0 or equivalent recommended)
  • All of the official add-ons require XenForo 2.1.
  • Enhanced Search requires at least Elasticsearch 2.0.
Installation and upgrade instructions

If you are already running XenForo 2.1.0, you will be pleased to know that you can easily upgrade to this version using the new One-click upgradessystem. If you would like to do this, remember to uncheck the "Only check for stable upgrades" option in Options > Basic board information.

Otherwise, full details for how to install and upgrade XenForo can be found in the XenForo manual.

Note that the official add-ons must be upgraded after upgrading to XenForo 2.1.

Please remember that this is beta/preview software. It contains known bugs and incomplete functionality. We do not recommend or support running beta software in a production environment. Support for beta releases is limited to questions here on the community forums.

 

vuicode

New member
Credits
20

Bạn kiểm tra file /src/XF.php
được rồi bạn ạ
chạy update bị lỗi

[B]XF\Db\Exception[/B]: Too many connections in [B]src/XF/Db/Mysqli/Adapter.php[/B] at line [B]160[/B]
[LIST=1]
[*][B]XF\Db\Mysqli\Adapter->makeConnection()[/B] in [B]src/XF/Db/Mysqli/Adapter.php[/B] at line [B]28[/B]
[*][B]XF\Db\Mysqli\Adapter->getConnection()[/B] in [B]src/XF/Db/AbstractAdapter.php[/B] at line [B]60[/B]
[*][B]XF\Db\AbstractAdapter->connect()[/B] in [B]src/XF/Db/AbstractAdapter.php[/B] at line [B]83[/B]
[*][B]XF\Db\AbstractAdapter->query()[/B] in [B]src/XF/Db/AbstractAdapter.php[/B] at line [B]101[/B]
[*][B]XF\Db\AbstractAdapter->fetchOne()[/B] in [B]src/XF/Session/DbStorage.php[/B] at line [B]30[/B]
[*][B]XF\Session\DbStorage->getSession()[/B] in [B]src/XF/Session/Session.php[/B] at line [B]53[/B]
[*][B]XF\Session\Session->start()[/B] in [B]src/XF/App.php[/B] at line [B]869[/B]
[*][B]XF\App->XF\{closure}()[/B] in [B]src/XF/Container.php[/B] at line [B]28[/B]
[*][B]XF\Container->offsetGet()[/B] in [B]src/XF/Install/App.php[/B] at line [B]38[/B]
[*][B]XF\Install\App->XF\Install\{closure}()[/B] in [B]src/XF/Container.php[/B] at line [B]28[/B]
[*][B]XF\Container->offsetGet()[/B] in [B]src/XF/App.php[/B] at line [B]2505[/B]
[*][B]XF\App->session()[/B] in [B]src/XF/Install/App.php[/B] at line [B]176[/B]
[*][B]XF\Install\App->setupUpgradeSession()[/B] in [B]src/XF/Install/Controller/Upgrade.php[/B] at line [B]20[/B]
[*][B]XF\Install\Controller\Upgrade->preDispatchController()[/B] in [B]src/XF/Install/Controller/AbstractController.php[/B] at line [B]11[/B]
[*][B]XF\Install\Controller\AbstractController->preDispatchType()[/B] in [B]src/XF/Mvc/Controller.php[/B] at line [B]123[/B]
[*][B]XF\Mvc\Controller->preDispatch()[/B] in [B]src/XF/Mvc/Dispatcher.php[/B] at line [B]320[/B]
[*][B]XF\Mvc\Dispatcher->dispatchClass()[/B] in [B]src/XF/Mvc/Dispatcher.php[/B] at line [B]248[/B]
[*][B]XF\Mvc\Dispatcher->dispatchFromMatch()[/B] in [B]src/XF/Mvc/Dispatcher.php[/B] at line [B]100[/B]
[*][B]XF\Mvc\Dispatcher->dispatchLoop()[/B] in [B]src/XF/Mvc/Dispatcher.php[/B] at line [B]50[/B]
[*][B]XF\Mvc\Dispatcher->run()[/B] in [B]src/XF/App.php[/B] at line [B]2177[/B]
[*][B]XF\App->run()[/B] in [B]src/XF.php[/B] at line [B]392[/B]
[*][B]XF::runApp()[/B] in [B]install/index.php[/B] at line [B]14[/B]
[/LIST]

 

dinhphucv

Well-known member
Staff member
Administrator
Moderator
Uploader
XF Premium
Credits
2.246
Bạn chuyển diễn đàn về chế độ bảo trì rồi update! Chép đè hết file cũ
 

dinhphucv

Well-known member
Staff member
Administrator
Moderator
Uploader
XF Premium
Credits
2.246
Cảm ơn Admin. Mà site này vẫn chạy v2.0.12 nhỉ
:3 chắc quên ai rồi! Đồng hương đó 😂! Xài 2.0.12 cho lành, add-ons với styles chưa hỗ trợ, đợi chính thức lên luôn!
 

Bcat

Member
Uploader
Credits
79
:3 chắc quên ai rồi! Đồng hương đó 😂! Xài 2.0.12 cho lành, add-ons với styles chưa hỗ trợ, đợi chính thức lên luôn!
có quên đâu, nói vậy để nâng cao e lên :D admin mà xD
 

Bcat

Member
Uploader
Credits
79
:3 chắc quên ai rồi! Đồng hương đó 😂! Xài 2.0.12 cho lành, add-ons với styles chưa hỗ trợ, đợi chính thức lên luôn!
IO dark với UIX dark e thích dùng cái IO này hơn ah? Hay nó tốt hơn cái UIX Dark?
 

dinhphucv

Well-known member
Staff member
Administrator
Moderator
Uploader
XF Premium
Credits
2.246
IO dark với UIX dark e thích dùng cái IO này hơn ah? Hay nó tốt hơn cái UIX Dark?
Em thích cài này hơn!!! Nói chung hai cái cũng tựa tựa nhau anh! Cái này nó có hiệu ứng :ROFLMAO:
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Chủ đề tương tự

Chủ đề thịnh hành

Top